Installation Guide

Python 2.7 Support

In the Fall 2019, we will be dropping support for Python 2.7. This follows movement from other packages within the scientific Python ecosystem. This includes:

The last release of MetPy before this time (Spring or Summer 2019) will be the last that support Python 2.7. This version of MetPy will not receive any long term support or additional bug fix releases after the next minor release. The packages for this version will remain available on Conda or PyPI.

Requirements

In general, MetPy tries to support minor versions of dependencies released within the last two years. For Python itself, that means supporting the last two minor releases, as well as currently supporting Python 2.7.

  • matplotlib >= 2.0.0
  • numpy >= 1.11.0
  • scipy >= 0.17.0
  • pint >= 0.8
  • xarray >= 0.10.7
  • traitlets >= 4.3.0
  • enum34 (for python < 3.4)
  • pooch >= 0.1, < 0.3

Installation

The easiest way to install MetPy is through pip:

pip install metpy

If you are a user of the Conda package manager, there are also up-to-date packages for MetPy (as well as its dependencies) available from the conda-forge channel:

conda install -c conda-forge metpy

The source code can also be grabbed from GitHub. From the base of the source directory, run:

pip install .

This will build and install MetPy into your current Python installation.

Examples

The MetPy source comes with a set of example scripts in the examples directory. These are also available as notebooks in the gallery in the Examples.